Plastiq unavailable

Incident Report for Plastiq

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 13:02 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 12:34 EST

Update

Platform is still experiencing intermittent availability. Our teams remain actively engaged and continue to work closely with our external partner to stabilize the environment.
Posted Nov 18, 2025 - 11:39 EST

Investigating

We are investigating reports that Plastiq (https://Plastiq.com/) is intermittently unavailable. We are actively researching and will provide more information shortly.
Posted Nov 18, 2025 - 07:42 EST
This incident affected: Plastiq.